Mainsail OS / Klipper Wlan Netzwerk ändern

  • Hallo,

    ich finde dazu absolut nichts wie man das Wlan Netzwerk ändern kann ....
    Mit Putty und sudo raspi-config geht es nicht (speichert es nicht ab) und die mainsailos-wpa-supplicant.txt kann ich weder löschen bearbeiten noch irgendwas.. kann das sein das das nicht möglich ist ?
    Such jetzt seit Ewigkeiten auf google finde dazu nichts

    Grüße

  • Quote

    Zitat von Olli66 am 14.03.2022, 19:18 Uhr


    Im laufenden Betrieb geht das nur mit dem Editor. Nimm doch die Karte aus dem Raspi raus und editiere sie am PC.


    hey die Idee hatte ich auch schon nur lässt sich da nichts öffnen ....
    sobald ich die karte in Kartenleser mache kommt immer wieder das Fenster formatieren aber zugreifen kann ich auf nichts

  • Formatieren abbrechen, dann solltest du doch auf die Karte zugreifen können.

    Oder den Raspberry Pi Imager verwenden, da kannst du das gleich anlegen.

    Ratrig V-Core 3, Bambu Lab X1C 2x AMS

  • Quote

    Zitat von Uwe R. am 14.03.2022, 20:08 Uhr


    Wie Olli es sagt. Im Pi Imager wie bei OctoPi mit Strg + Umschalt + X vor dem Schreiben auf SD-Karte.


    das weiß ich das war ja nicht das problem ich hatte nur keine lust alles neu zu installieren und konfigurieren ich musste eine bestehende ändern.



    grüße

  • Ich hol den Beitrag mal aus der Versenkung.


    Hab das selbe Problem, neues Netzwerk, am Klipperscreen lässt sich das alte Netzwerk nicht löschen und das neue nicht anlegen.


    Hab jetzt die SD-Karte angesehen, weiß aber nicht, wo ich die Verbindungseinstellungen finde um sie editieren zu können.

    In der config.txt steht nix zum Netzwerk und ansonsten gibt's da nix was ich öffnen könnte.


    Wie geht das denn nun ohne die Karte neu flashen zu müssen?

    Sidewinder X2 / Klipper / Orca Slicer 2.0.0 / Fusion360

  • Ich habe den Raspi per LAN mit dem PC verbunden. Bekomme aber mit Putty keine Verbindung.

    Habe in der Konsole mit ipconfig nach der IP geschaut und alle durchprobiert, gefühlt ist der Raspi nicht zu finden. Bekomme immer ne Fehlermeldung. Welche Bezeichnung sollte er denn haben?

    Bin da jetzt nicht der Crack daher versuche ich solche Sachen immer zu vermeiden aber der neue Router zwingt mich nun dazu. :D

    Sidewinder X2 / Klipper / Orca Slicer 2.0.0 / Fusion360

  • Den Pi müsstest du mit dem Router per LAN Kabel verbinden. Dann bekommt er vom Router automatisch eine passende IP Adresse und du kannst von deinem Rechner aus drauf zugreifen ( IP des Rpi im Router nachschauen ).


    Direkt am Rechner müsstest du erst passend konfigurieren.

  • Also, am Router eingestöpselt geht's natürlich. :)
    Hab aber ein neues Problem: Der Router ist neu, ebenso das Passwort für das Wlan. Der Netzwerkname ist der selbe geblieben.

    Jetzt meckert Klipper, dass das Netzwerk schon besteht und nicht überschrieben werden kann.


    Wenn ich diesen Befehl eingebe:

    Code
    sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

    Soll das erscheinen:

    Code
    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1
    country=DE
    Code
    network={   ssid="WLAN-SSID"   psk="WLAN-PASSWORT"
    }

    Zweiteres, also die vorhandenen Netzwerke werden nicht angezeigt.


    Ich habe mich dann wie weiter unten in der Anleitung und Punkt 3 beschrieben, als "root" angemeldet und das neue Netzwerk angelegt. Tja, ohne vorher das alte zu entfernen, funktioniert das nicht.


    Frage: Wie löscht man eine bestehende Netzwerkverbindung?

    Sidewinder X2 / Klipper / Orca Slicer 2.0.0 / Fusion360

  • Da du ja jetzt SSH Zugriff hast sollte das aus Punkt 1 / 2 mit raspi-config eigentlich funktionieren.

    Dann mußt du nicht in Dateien rumschreiben.


    Ansonsten steht bei Network={ was drin ? Könnte sein das der Klartext Name in eine Hash Zahl umgewandelt wurde.


    Wenn du die Datei mit sudo nano ... öffnest hast du auch root Rechte das kommt also aufs selbe raus.

    Edit: doch nicht hab's nachgelesen sudo -i :D


    Funktioniert das testweise verbinden?

    Code
    sudo wpa_supplicant -i wlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf

    Edited 3 times, last by ma_v ().

  • Ansonsten steht bei Network={ was drin ? Könnte sein das der Klartext Name in eine Hash Zahl umgewandelt wurde.

    Der ganze Block erscheint bei mir nicht. Nur der erste oben gezeigte. Weiter wird kein Network angezeigt.


    Hab es jetzt mit raspi-config probiert. Es kommt immer ne Fehlermeldung. :rolleyes:

    In der Konsole steht dann die Fehlermeldung, dass die eingegebene SSID nicht gefunden wurde. Die ist aber richtig geschrieben, Empfang ist vorhanden.

    Ich kann jetzt das Gast-Wlan nutzen, finde das aber unglücklich.

    Sidewinder X2 / Klipper / Orca Slicer 2.0.0 / Fusion360

  • Hab mal bei mir reingeschaut ( auch Mainsail OS ) da sieht das so aus:

    Code
    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
    update_config=1
    country=DE
    
    network={
            ssid="FRITZ!Box 7490"
            psk="dein passwort"
    }

    Eventuell ist was falsch geschrieben ? oder eine Klammer fehlt?

  • Ich habe jetzt nochmal mit

    Code
    cat /etc/wpa_supplicant/wpa_supplicant.conf

    nachgesehen, da wurde dann die korrekte SSID und Kennwort angezeigt. Also abgestöpselt und an den Drucker gehängt. Dort findet er das WLAN nicht. Verstehe ich nicht, das hat an selber Stelle vorher auch funktioniert, am Handy habe ich vollen Empfang. Dieser kleine Raspi geht mir grad gehörig auf den Zeiger. Auf mich wirkt es grad, als ob der Wlan-Empfang Probleme macht.

    Sidewinder X2 / Klipper / Orca Slicer 2.0.0 / Fusion360

  • Ich seh im Routermenü dass er offline ist und im Klippermenü, dass er das Netzwerk nicht findet.


    Ich werde ihn jetzt mal wo anders anstecken und schauen ob er dann das Netzwerk findet.

    Sidewinder X2 / Klipper / Orca Slicer 2.0.0 / Fusion360

  • Also, hab den Raspi im Flur angesteckt. In Klipperscreen wird die SSID gefunden und dahinter steht in Klammern "Verbunden". Das Empfangssymbol vorne dran hat aber ein rotes Ausrufezeichen.
    Im Routermenü ist der Drucker offline. Kurz darauf kommt im Klipperscreen ne Fehlermeldung und die SSID verschwindet. Wird auch nicht wieder gefunden.

    Was ist das für ein Krampf? Da steckt doch keine Logik dahinter? Ich habe jetzt drölfzig Geräte im neuen Netzwerk angemeldet nur der kleine Nervkeks stellt sich quer.


    Ich habe zwischenzeitlich auch ein Backup auf die SD-Karte gespielt. Allerdings bin ich mir nicht sicher, ob ich die Dateien gesichert hatte, als ich das Netzwerk bereits eingerichtet hatte.
    Dann habe ich einen anderen Raspi ausprobiert, selbes Problem.


    So, nach einer Weile findet er die SSID wieder, das rote Ausrufezeichen ist weg, wenn man aber auf den Pfeil rechts drückt und dann wieder auf die Übersicht zurück geht, ist die SSID wieder weg. Und im Routermenü ist er durchgehend offline.


    Was kann ich noch ausprobieren?

    Sidewinder X2 / Klipper / Orca Slicer 2.0.0 / Fusion360

Disclaimer:
*Externe Links enthalten Affiliate Daten. Wird über diese Links etwas bestellt, erhalten wir eine kleine Provision, Euch kostet es nichts Extra.
**Als Amazon-Partner verdienen wir an qualifizierten Verkäufen.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!

Unread Threads

    1. Title
    2. Replies
    3. Last Reply
    1. Neptune 4 pro, Probleme mit dem Leveln 2

      • TomKla
    2. Replies
      2
      Views
      101
      2
    3. ma_v

    1. Anycubic Kobra 2 - Kein Filament mehr aus der Düse, Filamentwechsel geht nicht 6

      • Neddard
    2. Replies
      6
      Views
      81
      6
    3. sentinell

    1. X1C - Scheiben reinigen

      • Nobody4711
    2. Replies
      0
      Views
      29
    1. Lacksuche Metallic oder Perlglanz oder? 5

      • lightsource
    2. Replies
      5
      Views
      114
      5
    3. lightsource

    1. X1C rattert über das infill 8

      • nibi
    2. Replies
      8
      Views
      293
      8
    3. sikoprint