Meshleveln klappt nicht

  • Hi, Ich habe einen Anycubic i3Mega Pro mit Knutwurst firmware. Die Firmware habe ich aufgespielt da ich extreme Probleme hatte mit verzogenen Druckbetten ,und man hier Meshleveln kann. Ich habe mich für die variante Ohne BL Touch entschieden, da ich mir die Installation nicht zutraue. Ich habe also die Funktion genutzt und ich habe den Eindruck dass hier was nicht stimmt. Der Druck ist unsauber und haftet nicht oder nur manchmal auch nicht mit Brim und es scheint entweder daran zu liegen dass die Düse zu hoch ist oder der "strahl" zu dünn, Ich habe mit einer fühlerleere gelevelt auf 0.09, ich habe auch die End Schalter mit Wasserwaage gerade eingestellt, man sieht wie das Material aus der Düse kommt also quasi "runterfällt" es ist nicht 100% so wie ich es beim Meshleveln eingestellt habe Sprich die düse scheint zu hoch zu sein. Ich drücke immer auf Save Eeprom wenn ich am ende angekommen bin und habe heute schon 5 mal gelevelt. Ich habe auch versucht einfach bis ich wieder an stelle 1 angekommen bin zu leveln und dann erst Save Eeprom gedrückt aber der Spalt der beim drucken zu sehen ist ist größer als der den ich eingestellt habe beim leveln. Ich verstehe das nicht manchmal kräuselt sich das material auch wenn ich n der luft Extrudiere sollte das nicht grade nach unten gehen? Ich weiss echt nicht weiter, kann hier vielleicht einer Helfen?

  • Ja ist drin



    G21 ; metric values

    G90 ; absolute positioning

    M82 ; set extruder to absolute mode

    M107 ; start with the fan off

    M140 S{material_bed_temperature_layer_0} ; Start heating the bed

    G4 S60 ; wait 1 minute

    M104 S{material_initial_print_temperature} ; start heating the hot end

    M190 S{material_bed_temperature_layer_0} ; wait for bed

    M109 S{material_initial_print_temperature} ; wait for hotend

    M300 S1000 P500 ; BEEP heating done

    G28 X0 Y10 Z0 ; move X/Y to min endstops

    M420 S1 ; Enable leveling

    M420 Z2.0 ; Set leveling fading height to 2 mm

    G0 Z0.15 ; lift nozzle a bit

    G92 E0 ; zero the extruded length

    G1 X50 E25 F500 ; Extrude 25mm of filament in a 5cm line.

    G92 E0 ; zero the extruded length again

    G1 E-2 F500 ; Retract a little

    G1 X120 F4000 ; Quickly wipe away from the filament line`

  • Ich hab gelesen dass das normal sein kann, die erste Schickt wird ja anders gedruckt als die anderen, also bei mir ist die auf 0,4 mm eingestellt. Ich habe auch festgestellt dass die Nozzle immer näher ans Bauteil kommt bis sie schließlich irgendwann zu nah dran ist. Grade hab ich einen schlechten druck gehabt und während des drucks das Bett runter gedreht und es verbeserte sich promt. nun wird es aber beim nächsten druck in der ersten Schicht viel zu seit weg sein sodass ich wieder hochdrehen muss. das verstehe ich nicht

  • So sehen entsprechen die drucke aus den einen musste ich abbrechen


    Hab mal noch in dem Link mein Profil von Cura dass ich für das petg drucken verwende hochgeladen. Das wird vermutlich die reinste Katastrophe sein weil ich noch am testen bin, aber weis auch nicht was ich da alles verstellen soll, da sind schon viele Tutorials reingeflossen jeder sagt was anderes.


    File-Upload.net - PETGprofil.curaprofile

  • Es gibt da ein gewisses Prozedere das man beim Mesh Leveling mit der knutwurst FW durchgehen sollte. Ich komme aber gerade nicht drauf was genau man machen sollte das die Mesh Werte auch übernommen werden. Vieleicht mal den Entwickler anschreiben oder in der Facebook Gruppe nachfragen?

    Soweit ich mich erinnern kann bekommt man die gespeicherten Werte nach dem Mesh Leveling mit M503 in einem Terminal auch angezeigt. Was meldet denn dein Drucker da?


    Arbeitest du zufällig mit Octoprint an dem Drucker weil dort gibt es das Plugin Bed Visualizer mit dem man sich die ermittelten Werte recht einfach grafisch darstellen kann.

  • Ich habe octoprint ist im Moment außer betrieb aber das kann ich in 2 min einschalten nur in wie fern hilft es diese werte grafisch zu sehen , ich meine was kann ich dem entnehmen? Facebook habe ich nicht gibt es noch andere Kontaktmöglichkeiten? ich habe mal versucht das über email zu machen aber ohne Erfolg

  • Naja, wenn du dein Druckprofil nicht richtig eingestellt hast, dann kann das schon dazu führen, dass es nicht wirklich funktioniert.

    Wenn du dein Bed auf 0,1mm eingestellt hast, und deine Extrudersteps und der Flow passen nicht, dann würde ich mal eher da ansezten. Wenn da zuviel Material raus kommt, ist es ja logisch, dass die Nozzle drin rum fährt.

    Wenn du das Bed manuell runterstellst, dann löst es dein Problem ja nicht.

    Stell die anderen Sachen mal richtig ein.

  • Naja, deine E-Steps müssen schon passen, da ist nichts mit probieren. Entweder sie sind richtig oder falsch. Und wenn die nicht passen, dann sind alle anderen Einstellungen eh hinfällig.

    Stell die Steps mal ein, dann levelst du, stellst dann den flow ein und du wirst sehen, wie es dann aussieht.

    Nicht während dem Druck am Bed rumschrauben. Das ist der falsche Ansatz.

    Für Steps und Flow gibt es hier oder bei youtube genug anleitungen.

  • Ich habe octoprint ist im Moment außer betrieb aber das kann ich in 2 min einschalten...

    Mach das mal. Ruf das Webif vom Raspi auf und gehe auf den Reiter "Terminal". Unter der Befehlszeile findest du die Suppress-Optionen der Ausgaben...überall Haken setzen und der Übersichtlichkeit halber die Ausgabe löschen. Dann über die Befehlszeile M503 an den Drucker senden, die Ausgabe kopieren und hier einfügen. Dann schauen wir mal drüber :)


    BTW: Mesh-Leveling ist kein Zaubermittel. Ein zu krummes oder manuell schlecht geleveltes Bett kann das auch nicht kompensieren.

    Ein Leben ohne 3D-Drucker ist möglich, aber sinnlos. (Frei nach Loriot)

    Edited once, last by 0.02 Inch ().

  • Die Werte des Mesh-Levelings sind schon mal im Speicher. Das ist schonmal gut. Nicht gut sind hingegen die Werte. Man kann daraus schließen, daß du das manuelle Leveln über die Schrauben vorher vernachlässigt hast. Der Höchstausschlag von 0,3 mm ist eindeutig zu viel.


    Hattest du den Extruder schon einmal kalibriert? Der Wert weicht auch relativ stark vom Standardwert ab.


    Meine ehrliche Meinung? Reset to Firmware Defaults oder M502 gefolgt von M500 an der Konsole und alles neu kalibrieren.

    Ein Leben ohne 3D-Drucker ist möglich, aber sinnlos. (Frei nach Loriot)

  • Ich hab gestern nichts anderes als leveln gemacht ich hatte aber das Problem dabei dass die End Anschläge beim leveln betätigt wurden man hörte immer das klicken und das bevor ich auf der richtigen höhe war also die fühlerleere ging zu einfach durch also musste ich erstmal schaun dass ich das hoch mache, und anschliessend das ganze bett hochmache damit der abstand nicht zu hoch ist dann habe ich z mit wasserwaage grade gemacht indem ich die End Anschläge rechts und links immer einzeln rein oder raus geschraubt habe und anschließend das Bett gelevelt und danach mesh. es kann natürlich sein dass da durch das ändern der z anschläge was nciht stimmt aber ich hatte das problem anfangs das die 4 bettschrauben so weit raus gedreht werden mussten dass sie einfach lose waren also hab ich Z runter gemacht damit ich mit den schrauben weiter rein konnte. und jedesmal neu mesh gelevelt

  • Dann krieg das erstmal mit den Endstopps und den Bettschrauben in den Griff. Wenn das Bett über die Schrauben eine stabile und hinreichend gerade Position hat, Endstopps nachjustieren, mechanisch leveln und zu krönenden Abschluß dann das Meshleveling durchführen. Mein Tipp...

    Ein Leben ohne 3D-Drucker ist möglich, aber sinnlos. (Frei nach Loriot)

  • Die Endstopps habe ich ja schon grade gemacht mit der Wasserwaage. das sollte so jetzt eigentlich passen. ich habe nur den Eindruck dass es nicht 100%gespeichert wird. wie genau muss ich das deuten mit dem Höchstausschlag? wo sehe ich daS? ich kann mit den werten nicht so richtig was anfangen..

  • Jeder Wert wird beim Ansteuern des nächsten Meßpunkts vorläufig gespeichert. Alle Werte zusammen werden dann durch "SAVE TO EEPROM" oder durch M500 dauerhaft in den Speicher geschrieben, zumindest bis zu nächsten Firmware-Update oder einem Reset to Defaults. Und das, was du gemessen hast, zu 100%. Da gibt es kein ~51%. :)

    Apropos Fühlerlehre...wie dick is'n die?


    BTW; Wenn du schon eine Wasserwaage für das Bett benutzt, sollten auch das Gehäuse und die Führung der X-Achse waagerecht sein.

    Ein Leben ohne 3D-Drucker ist möglich, aber sinnlos. (Frei nach Loriot)

    Edited once, last by 0.02 Inch ().

  • Ok ich verstehe nicht wie ich erkenne dass es 0,3 mm unterschied sind die du gesehen hast wie kann ich die Meshwerte lesen ich blick da nicht durch.


    Ich habe eine Fühlerleere mit verschiedenen Größen das ist so ein fächer von 0,001 bis 1,00 ich habe es versucht mit 0,10 ,0,09, 0,05 zuletzt habe ich wieder 0,09 genommen. Mit der Wasserwaage habe ich nicht das Bett gelevelt, ich hab es auf die Z Achse gelegt da ich ja 2 End Schalter habe damit diese Grade ist


    mir ist nur aufgefallen wenn ich jetzt zum Beispiel das Bett mit der Meshleveling funktion komplett auf die 0.09er fühlerleere einstelle so das diese saugend zwischen Bett und Nozzel durchgeht und die nozzle dann wieder auf Position 1 fährt dann kann ich das leveling endlos durchführen ich habe immer wieder diesen anfänglichen größeren abstand und nicht die 0,09 egal ob ich am ende save to eeprom mache ob ich Speicher wenn er auf pos1 fährt oder an der letzten pos. er scheint das nicht zu übernehmen.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!

Unread Threads

    1. Title
    2. Replies
    3. Last Reply
    1. Filamentspulen... 22

      • Uwe
    2. Replies
      22
      Views
      259
      22
    3. tecneeq

    1. Tage lang druckte der X1 ohne Probleme, und jetzt..? 31

      • M1-iMac-Alex
    2. Replies
      31
      Views
      634
      31
    3. Gruma 3D Druck

    1. Probleme mit Flow einstellen 34

      • Bekhesh
    2. Replies
      34
      Views
      390
      34
    3. raimondovincenti

    1. Sunlu Terminator T3 1

      • Peter_O
    2. Replies
      1
      Views
      144
      1
    3. Peter_O

    1. SV06 210

      • Guden79
    2. Replies
      210
      Views
      5k
      210
    3. DIYLAB