V400 Update auf Original Klipper nach Guilouz

  • Also aktueller Status: Ich komme auf das SpeederPad drauf, ich kann die IP Adresse aber nicht wechseln. Auf GitHub gibt es einen Absatz dazu:
    https://github.com/Guilouz/Kli…d#set-a-static-ip-address
    ... das wollte ich jetzt machen, damit die IP endlich passt (auch kein DHCP mehr), aber ich darf nicht:

    mkdir /root/speeder_pad

    => Das funktioniert nicht, ich bekomme sofort den Fehler

    mkdir: cannot create directory ‘/root/speeder_pad’: Permission denied


    ??
    Muss ich "root" durch was anderes ersetzen?
    Kapier es grad (wieder mal) nicht...

  • ist der Ordner /root überhaupt vorhanden?


    mach doch mal

    ls -ali /

    um zu schauen ob der ordner /root da ist


    dann als welcher user bist Du angemeldet?

    mit user pi ?


    dann probier doch mal

    sudo mkdir /root/speeder_pad


    und dann das passwort vom pi

  • Jesus Christ.
    Also die Anleitung ist schon extrem wörtlich zu nehmen.
    Ich habe inzwischen den root access eingestellt und auch eine feste IP. Ich kann also wieder drauf auf die Kiste, war aber sehr ungewohnt. Geflasht habe ich immer noch nicht, denn meine Karte funktioniert einfach nicht. Das FLSUN Logo blinkt zwar schon, aber der Name wird nicht in .Cur geändert.

    Wenn die andere Karte auch nix bringt (müsst heut kommen), dann mach ich einfach mal weiter und schau, ob es vielleicht schon so eingestellt gewesen ist (ich kanns mir aber kaum denken...) - so wie Laughing Pain meinte (wobei er noch nicht gesagt hat, ob das für ihn alles funtkioniert ohne cfg update...?

  • so, bin jetzt auch soweit.

    wegen dem Fehler mit "timelapse.cfg"

    in Mainsail -> Machine kannst Du die printer.cfg editieren und wenn Du da Zeile

    395 [include timelapse.cfg] #Load the camera recording function

    mit einem # auskommentierst ist zumindest mal der Fehler weg

  • Wenn man in den Root Ordner rein will, muss man root Zugang erst mal aktivieren und sich dann als root einloggen. Ist auch in der Anleitung beschrieben.

    Schon sperrig.

    Also, ich bin ja was Linux angeht echt ein unbeschriebenes Blatt...

    Ich musste mich auch als root anmelden um auf den root-ordner zu zugreifen um den Boot-Bildschirm ändern zu können.

    So wie es bei mir lief war es nicht ausreichend, mich als root anzumelden sondern die Session musste als root hergestellt werden. Kein Problem erstmal mit der Anleitung.

    Aaaaber....

    Ich weiss echt nicht, wo es da bei Euch klemmt, vielleicht hab ich einfach nur Glück gehabt?

    Bei mir ist das alles sauber durchgelaufen.

    Nachdem das SpeederPad nach der SD-Karte wieder da war konnte ich mich ganz normal wieder übers Interface des Pads mit meinem Wlan verbinden und dann per MobaXterm zugreifen.

    Auch das Flashen der Firmware war ne Sekundensache. SD auf auf 1 oder 2 GB verkleiner, FAT32 formatiert und dann stumpf der Anleitung gefolgt.

    Es hatte mal kurz geklemmt weil man bei den Einstellungen für den Firmware-Export auf der Karte schon GANZ GENAU hingucken muss.

    Aber davon abgesehen war das ein Spaziergang...

    Ihr seid Euch sicher, dass Ihr Euch da nicht irgendwo am Anfang schon verbastelt habt?


  • das update der Motherboard Firmware wird auch interessant, weil der MicroController auf meinem Board ein anderer ist


    Habe bis hier auch der Anleitung gefolgt und es ging bis auf "timelaps.cfg" prima

  • rpm8200

    hast du mal versucht das original Update von Flsun auf den Drucker zu flashen ?

    nicht das deine Datei einen Fehler hat ?

    Anycubic Mono X, Sovol SV04, Flsun V400,

    Bambu Lab X1-Carbon + 2 AMS / A1Mini + AMS lite

  • RadlSteve ich hab genau den selben drin. Ich habe GD32F103 ausgewählt. Die 303 gibts aber gar nicht zum Auswählen.
    Du hast alles durchgeführt ohne Flash... geht es denn bei Dir?

    Ist die 103 vom 303 abgelöst worden? Finde dazu nix im Web.

    blackbird2016 nachdem es bei Dir funktioniert hat - welche CPU hast Du drin?

  • rpm8200

    hast du mal versucht das original Update von Flsun auf den Drucker zu flashen ?

    nicht das deine Datei einen Fehler hat ?

    Hm. Also ich denke, das versuche ich jetzt noch nicht.
    Ich glaub zwar, dass ich im zweiten Anlauf schneller wieder dahin komme wo ich aktuell bin, aber ich versuche erst mal noch weiter zu flashen.
    Bin nicht sicher ob es ein Prob ist - ich habe wie RadlSteve den neueren 303 drin, nicht den 103, der in der Anleitung genannt ist und auch im Menue der Klipper FW Configuration...

  • Keine Ahnung, welche CPU.

    Müsste auch egal sein, wenn es Unterschiede gäbe, dann müsste FLSUN auch verschiedene Files zur Verfügung stellen. Nachdem sie das bisher nicht machen müssen die Boards die Updates fressen, egal weche CPUs drauf sind.

    Wenn sie das tun, dann müssen auch die "sauberen" Klipper-versionen damit arbeiten können.

    Es gibt ein Robin-nano V2.1 und dafür gibts Firmwares.

    Da kümmere ich mich als Kunde erstmal nicht darum, welcher Chip da im Einzelnen drauf ist...


    Würd mich echt mal interessieren, ob wir hier die Einzigen sind, die das "Upgrade" schon durchgeführt haben und ich wirklich der einzige Erfolgreiche sein soll.

    Wäre doch schön, Andere hätten das auch schon "gemeistert" und würden sich mal melden, dass man abschätzen kann, ob es grundsätzlich geht, oder ich nur Glück hatte und es mittlerweile ein generelles Problem gibt...

  • also momentan verspüre ich sehr wenig Lust das nochmal zu probieren,

    der Drucker läuft jetzt fast 2 Tage nonstop und macht was er soll,

    mal sehen

    Anycubic Mono X, Sovol SV04, Flsun V400,

    Bambu Lab X1-Carbon + 2 AMS / A1Mini + AMS lite

  • Also ich bin nach dem ganzen Gedöns schon motiviert, das auch hin zu bekommen.
    Ich werde schon weiter machen. Wills ja auch für meinen Kanal als Video haben.
    Hab schon tonnenweise Rohmaterial lol...

  • [...]

    Es gibt ein Robin-nano V2.1 und dafür gibts Firmwares.

    Da kümmere ich mich als Kunde erstmal nicht darum, welcher Chip da im Einzelnen drauf ist...

    [...]

    Klar, das würde mich auch nicht kümmern, wenn das Update funktionieren würde. Tuts nur eben nicht und ich suche nach Gründen warum. Ein Grund könnte die Karte sein (habs genauso gemacht wie Du, habs ja schon geschrieben, aber da passiert nix), ein anderer, dass das was in der Anleitung steht nicht zur Hardware passt.
    Na mal sehen...

  • rpm8200: ich habe die Robin_nano35.bin von der FLSUN Support Seite

    Dort unter Downloads -> SpeederPad die Confguration File V400

    in der .zip ist dann die Firmware. Die nutze ich aktuell.


    zum Konfigurieren und Beschreiben der Micro SDCard:

    ich habe das unter Windows folgendermaßen gemacht:

    Achtung! lieber 2x prüfen dass die richtige Disk und Partition selektiert ist

    Achtung! wenn die falsche Disk / Partition gewählt wird, ist wohlmöglich der Rechner platt...


    Eingabeaufforderung mit Adminrechten

    C:\> diskpart

    DISKPART> LIST DISK

    DISKPART> SELECT DISK X (die SDkarte)

    DISKPART> LIST PARTITION

    DISKPART> SELECT PARTITION X (die Partition auf der SDkarte auswählen)

    DISKPART> DELETE PARTITION OVERRIDE (die Partition löschen)

    DISKPART> CREATE PARTITION PRIMARY SIZE=1000

    DISKPART> EXIT


    damit solltest Du eine 1GB Fat32 Partition auf der SDkarte haben

    Ich habe das mit der 1GB Partition auf einer 16GB SDkarte gemacht und das hat prima funktioniert.

    V400 ausschalten, oben den Deckel aufmachen, SDkarte ins Mainboard stecken, einschalten.

    30sec. warten. V400 ausschalten, SDkarte im Rechner anschauen.

    Der Dateiname sollte sich in ROBIN_NANO35.BIN.CUR geändert haben

    V400 einschalten...

  • RadlSteve


    ich mach mal hier weiter,

    du hast also die .bin-Datei für den Drucker nicht selbst erzeugt wie in der Anleitung steht sondern direkt die von Flsun genommen ?

    Anycubic Mono X, Sovol SV04, Flsun V400,

    Bambu Lab X1-Carbon + 2 AMS / A1Mini + AMS lite

  • @Zokl18

    ja genau. Ich denke das müsste passen, denn in der von FLSUN downloadbaren printer.cfg steht folgendes drin:


    Da die Drucker ja immer noch damit ausgeliefert werden müsste das passen.

    Ich mache heute Abend die Kalibrierungen durch, dann kann ich genauer berichten ob das tatsächlich so ist.

    Im aktuellen Klipper gibt es wohl noch keinen Support für die bei mir verbaute CPU GD32F303 allerdings habe ich gelesen das man einfach die STM32F103 nehmen kann so wie das in der offiziellen Firmware wohl auch gemacht wird.

    Vielleicht teste ich das auch noch mit selbst gebauter Firmware, aber jetzt versuche ich das erst mal mit der originalen.

    Die ersten Tests wie Homing und Bett/Düse heizen und Filament extrudieren was ich gestern Abend gemacht habe, haben jedenfalls geklappt.

  • Also ich habe die Firmware selber über Klipper gemacht. Das ist ja der Sinn der Sache, dass man diese Config richtig macht und dann die daraus erzeugte Firmware passt.
    Ich habe die Partition immer über das Computer Management gemacht, sollte auch passen. Allerdings habe ich nicht als Primary Partition sondern als Simple Volume formattiert. So wie Du geschrieben hast, ist auch die Größe der Zuweisungseinheiten unklar bzw. nicht definiert (würde mich wundern, wenn es zufällig 4096 wären).

    Ich hab inzwischen meine Installation durch, bis zum Schluss. Ich habe lediglich die Firmware Retraction weg gelassen. Drucker verbindet, keine Fehler. Ich habe aber noch nichts gedruckt, da ich die Kalibrierung noch nicht gemacht habe (und auch die will ich dokumentieren für meinen YT Channel).


    Die SD Karte ist auch angekommen... lol, die ist so klein dass es wiederum 4096 nicht gibt. Sowas. Na gut, ich versuche es nun mit 2048. Mal sehen, ob das dann klappt. Ich melde mich wieder (k.A. wann ich Zeit hab).

Disclaimer:
*Externe Links enthalten Affiliate Daten. Wird über diese Links etwas bestellt, erhalten wir eine kleine Provision, Euch kostet es nichts Extra.
**Als Amazon-Partner verdienen wir an qualifizierten Verkäufen.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!

Unread Threads

    1. Title
    2. Replies
    3. Last Reply
    1. A1 Heizbett Kabel Rückruf 428

      • jazznow
    2. Replies
      428
      Views
      27k
      428
    3. Michael

    1. Creality K1C Hilfe 3

      • AK2024
    2. Replies
      3
      Views
      21
      3
    3. Pommeraner

    1. Meine meinung und Erfahrungen zum a1 mini 32

      • Capt-nauti
    2. Replies
      32
      Views
      1.5k
      32
    3. PeterK

    1. Drucker hört auf einmal auf zu Drucken...nur Schalter hilft. 105

      • Xavier74
    2. Replies
      105
      Views
      1.4k
      105
    3. Menorix

    1. Anycubic I3 Mega 9

      • SDScaleDesignsRC
    2. Replies
      9
      Views
      144
      9
    3. 0.02 Inch