KAMP (Klipper Adaptive Mesh and Purging) funzt ned

  • Hola Klipperos,


    ich habe meinen K1 gerootet. Nach der Anleitung von https://github.com/Guilouz/Cre…-and-K1-Max/wiki/Use-KAMP (die vorbereitenden Schritte habe ich bereits durchgeführt, SSH und fluidd funktionieren) möchte ich das Adaptive Mesh haben. Das funktioniert aber nicht.


    Was habe ich gemacht:

    • KAMP installiert (keine Fehlermeldung)
    • alle Schritte der Anleitung, genau so wie sie dastehen, befolgt
    • in Creality Print Experimental>Exclude Objects gesetzt
    • bei der WLAN-Übertragung "Print Calibration" angehakt

    Ergebnis: Es wird kein Adaptive Mesh generiert. Jedenfalls bewegt sich der Druckkopf an die vier außersten Stellen des Bettes und nimmt da wohl auch eine Probe von der Betthöhe, aber auch ein 4x4-cm-großer Würfel führt nicht dazu, dass um diesen Bereich das Levelling durchgeführt wird.


    Gibt es irgend etwas, das nicht in der Guilouz-Anleitung steht, was ich beachten sollte?


    Was ich bisher probiert habe (weil es nicht explizit in der Anleitung steht)

    • In der printer.cfg [include KAMP_Settings.cfg] probeweise am Anfang, nach den includes und am Ende angefügt
    • SET_VELOCITY_LIMIT ACCEL={printer.configfile.settings.printer.max_accel} habe ich nicht eingefügt
    • Creality Print > "Print Calibration" an- und ausgeschaltet. Bei "Print Calibration" werden die vier Ecken angefahren, aber keine Kalibrierung um das Objekt herum ausgeführt. Ohne "Print Calibration" fängt der K1 direkt an zu drucken.

    Hat schon jemand KAMP auf dem K1 zum Laufen gebracht? Wo liegt mein Fehler? Jeder Testlauf kostet mich ja immer so 10 min, bis der Drucker anfängt zu drucken, das ist sehr zeitaufwendig.


    Und: Wie kann ich die debug-Ausgaben von KAMP sehen, damit ich in der Konsole sehen kann, was passiert?


    Ne Idee?

  • Hast du in deinem Start-G-Code im Slicer ein

    Code
    M117

    drin stehen? Wenn nicht, füge es ein, ähnlich wie hier und versuche es erneut


    Code
    M104 S0
    M190 S0
    M117
    M190 S[first_layer_bed_temperature]
    PRINT_START xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
  • Ah, hatte ich versäumt. Mein Startcode sieht so aus:

    Code
    M140 S0
    M104 S0 
    M117
    START_PRINT EXTRUDER_TEMP=[material_print_temperature_layer_0] BED_TEMP=[material_bed_temperature_layer_0]
    SKEW_PROFILE LOAD=skew_profile_PLA

    Trotzdem kein Erfolg.

    Creality K1

  • Schau mal hier herein.
    Evtl. werden dort einige Fragen für dich beantwortet;

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

  • Durch experimentelle Datenverarbeitung bin ich schon ein Stück weiter: Wie in

    External Content youtu.be
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.
    beschrieben, habe ich

    Code
    [include ./KAMP/Adaptive_Meshing.cfg]

    mal versuchsweise in die printer.cfg eingefügt. Jetzt macht der Drucker wenigstens ein kleines Mesh.


    So ganz verständlich ist mir das nicht, warum das jetzt funktioniert, aber sei's drum.

    Creality K1

  • Hast du in deiner KAMP_Settings.cfg das "Adaptive_Meshing" überhaupt "eingeschaltet/aktiviert"?

    Code
    # Below you can include specific configuration files depending on what you want KAMP to do:
    
    [include ./KAMP/Adaptive_Meshing.cfg]
    # [include ./KAMP/Line_Purge.cfg] 
    # [include ./KAMP/Voron_Purge.cfg]
    # [include ./KAMP/Smart_Park.cfg]

    Das # vor der Zeile entfernt?


    .. und die "KAMP_Settings.cfg" in deiner printer.cfg "included"?

    Code
    # Include
    [include timelapse.cfg]
    [include KAMP_Settings.cfg]

    Edited 3 times, last by wwoody ().

  • Ja, gerade nochmal doppelt gecheckt. Stimmt soweit alles. Erst, als ich das Include in die printer.cfg kopiert habe, ab dann ging's. Wie gesagt, rätselhaft.

    Edit: Jetzt funktioniert es wieder nicht. Ich denke, ich mache Schluss mit dem Thema für heute, da setze ich mich nochmal dran, wenn ich Zeit und Muße habe.


    Bis hierhin danke ich erstmal allen Tippgebern.

    Creality K1

  • Moin,

    ich bin im Moment auch nicht weiter mit meinem Neptune 3 pro. Habe auch bei den entsprechenden Einträgen das # entfernt aber irgendwie funzt das nicht.

    Im Slicer (Cura 5.4.0) ist folgendes eingetragen:


    M117

    SETUP_KAMP_MESHING DISPLAY_PARAMETERS=1 LED_ENABLE=1 FUZZ_ENABLE=1

    BED_MESH_CLEAR

    BED_MESH_CALIBRATE




    Jemand eine Idee ?


    Gruß

    Daniel

  • Meiner Erfahrung nach müssen da gar keine speziellen Befehle für KAMP im Start_Code sein.

    Ich habe auch nur:

    BED_MESH_CALIBRATE

    M117

    und

    LINE_PURGE drin


    Allerdings läuft das bei mir über ein START_PRINT Macro und nicht über die BEfehle direkt im Slicer eingetragen.

  • KAMP braucht nichts im Startcode. Die Information an welchen Stellen sich das Druckopbekt befindet werden vom Slicer übergeben. Bei den meisten Slicern heisst die Option die man anhaken muss "Label Objects".


    Das zweite was dann noch in die Printer.cfg gehört ist [exclude_object]. Erst dann kann Klipper mit den Informationen die der Slicer via "Label Objects" in den gcode schreibt auch was anfangen.



    Es gibt noch eine andere Lösung (nicht KAMP) um einen bed Mesh nur an der Stelle des Druckobjektes zu machen. Ich nutze die zum Beispiel. Dabei wird wirklich im Startcode die Objekt Max und Min Koordinaten des Durckobjektes übergeben und via START_PRINT Macro verarbeitet. Hier im Prusaslicer Startcode als AREA_START und AREA_END übergeben.

    Code
     START_PRINT EXTRUDER=[first_layer_temperature] BED=[first_layer_bed_temperature] AREA_START={first_layer_print_min[0]},{first_layer_print_min[1]} AREA_END={first_layer_print_max[0]},{first_layer_print_max[1]}

    Aber wie gesagt das ist NICHT KAMP.

    --

    Flashforge Dreamer, Ender 3 Pro, Sovol SV06, FYSETC Mk3s+ Clone

  • Z_tilt brauchst du für den Neptune natürlich nicht.

Disclaimer:
*Externe Links enthalten Affiliate Daten. Wird über diese Links etwas bestellt, erhalten wir eine kleine Provision, Euch kostet es nichts Extra.
**Als Amazon-Partner verdienen wir an qualifizierten Verkäufen.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!

Unread Threads

    1. Title
    2. Replies
    3. Last Reply
    1. Supportseite verschwommen 12

      • Sora
    2. Replies
      12
      Views
      246
      12
    3. blackbird2016

    1. OT Thread für was Druckt Ihr gerade 801

      • seppel
    2. Replies
      801
      Views
      29k
      801
    3. Candy Pebbles

    1. A1 Heizbett Kabel Rückruf 443

      • jazznow
    2. Replies
      443
      Views
      27k
      443
    3. jenshs

    1. Brauche Hilfe 4

      • senolk
    2. Replies
      4
      Views
      66
      4
    3. Stephan

    1. Kamera verbinden 5

      • Pax123
    2. Replies
      5
      Views
      106
      5
    3. slap