Klipper state: Disconnect

  • Tach,


    ich wollte das Bedleveling durchführen, aber wenn er das Mesh speichern will, bekomme ich in der Konsole:

    Code
    21:09:07 Klipper state: Disconnect
    21:09:06 SAVE_CONFIG
    21:09:00 Bed Mesh state has been saved to profile [default]
    for the current session. The SAVE_CONFIG command will
    update the printer config file and restart the printer.
    21:09:00 Mesh Bed Leveling Complete


    Klippy.log gibt mir zigfach das hier aus:

    Code
    Stats 2956.6: gcodein=0  mcu: mcu_awake=0.007 mcu_task_avg=0.000081 mcu_task_stddev=0.000067 bytes_write=1352 bytes_read=6572 bytes_retransmit=9 bytes_invalid=6 send_seq=154 receive_seq=154 retransmit_seq=2 srtt=0.002 rttvar=0.000 rto=0.025 ready_bytes=0 upcoming_bytes=0 freq=15982630 heater_bed: target=0 temp=22.9 pwm=0.000  sysload=0.55 cputime=20.812 memavail=617808 print_time=0.001 buffer_time=0.000 print_stall=0 extruder: target=0 temp=23.1 pwm=0.000

    Tante Google macht dicke Backen, gab wohl mal einen ähnlichen Fehler, der aber vor rund einem Jahr behoben wurde. Update habe ich erst vor einer Stunde durchgeführt.


    Ahnt jemand, was das Ding von mir will oder welche Schmerzen es hat?


    Danke im Voraus

    Viele Grüße

    Michael

    Anycubic i3 Mega Klipper –– Qidi X-Smart 3 –– Artillery Sidewinder X2 Octo –– Sidewinder X3 Plus –– Creality Ender-3 V3 KE.
    Seit Jahren Anfänger.
    Meine Entwürfe auf Thingi. Was ich gerade drucke.

  • Klippy.log gibt mir zigfach das hier aus:

    Code
    Stats 2956.6: gcodein=0  mcu: mcu_awake=0.007 mcu_task_avg=0.000081 mcu_task_stddev=0.000067 bytes_write=1352 bytes_read=6572 bytes_retransmit=9 bytes_invalid=6 send_seq=154 receive_seq=154 retransmit_seq=2 srtt=0.002 rttvar=0.000 rto=0.025 ready_bytes=0 upcoming_bytes=0 freq=15982630 heater_bed: target=0 temp=22.9 pwm=0.000  sysload=0.55 cputime=20.812 memavail=617808 print_time=0.001 buffer_time=0.000 print_stall=0 extruder: target=0 temp=23.1 pwm=0.00

    Ich vermute, dass Klipper wieder connected ist, wenn diese Meldungen regelmäßig kommen. Such mal weiter oben im Log, ob über den Meldungen dann noch was anderes kommt was Aufschluss darüber geben kann, warum der Disconnect erfolgt ist.

    Bambu Lab P1S, Voron 2.4, Voron 0.2, Sovol SV01, KP3S, Anycubic i3 Mega S
    (alle Klipper bis auf Bambu)

  • Tja, mehr steht da auch nicht. Liest sich wie ein ansatzloser Shutdown. Aber auch die Zeilen davor deuten nicht auf den SAVE_CONFIG-Befehl hin. Als ob nach der Ausgabe der Leveldaten einfach die Firmware neu startet?
    So ganz ohne Timestamp ist das auch total schlecht nachzuvollziehen.

    Edit: Anderes, neues und kürzeres USB-Kabel und ein anderes Netzteil habe ich auch schon ausprobiert. Alle Netzteile und Kabel funktionierten zuvor mit Octo-Print einwandfrei.

    Edit 2: Am zweiten getesteten USB-Kabel ist auch noch der 5V-Anschluss abgeklebt, da der Sidewinder X2 sonst darüber mit Spannung versorgt wird.

    Anycubic i3 Mega Klipper –– Qidi X-Smart 3 –– Artillery Sidewinder X2 Octo –– Sidewinder X3 Plus –– Creality Ender-3 V3 KE.
    Seit Jahren Anfänger.
    Meine Entwürfe auf Thingi. Was ich gerade drucke.

    Edited 2 times, last by Hessi ().

  • Seltsam, da weiß ich auch nicht weiter.


    Wenn hier sonst keiner eine Idee hat, kannst Du das auch mal im Klipper-Discourse (Forum) suchen ob der Fehler da schon beschrieben wird oder einfach im Klipper-Discord fragen, vielleicht kann jemand spontan helfen. Die Adressen sind auf dieser Seite:

    https://www.klipper3d.org/Contact.html

    Bambu Lab P1S, Voron 2.4, Voron 0.2, Sovol SV01, KP3S, Anycubic i3 Mega S
    (alle Klipper bis auf Bambu)

  • Kannst ja mal das logextract.py Skript probieren, zumindestens liest sich die Beschreibung so, als ob es hilft ("There is a logextract.py script that may be useful when analyzing a micro-controller shutdown or similar problem"):


    Debugging - Klipper documentation

    Bambu Lab P1S, Voron 2.4, Voron 0.2, Sovol SV01, KP3S, Anycubic i3 Mega S
    (alle Klipper bis auf Bambu)

  • Da konnte ich bisher noch nicht posten. Oder auch mitlesen. Dieser Foren-Host ist empfindlich auf HTML5-Plugins. Musste ich erst austesten, welches das war (ein Smilie-Plugin). Das schiebe ich seit Tagen vor mir her und las nur in einem anderen Browser dort mit. Auf weiteres Gebastel hatte ich gestern gar keinen Bock mehr. Habe es nun aber erledigt.

    Das mit dem Script probiere ich später aus. Danke.

    Anycubic i3 Mega Klipper –– Qidi X-Smart 3 –– Artillery Sidewinder X2 Octo –– Sidewinder X3 Plus –– Creality Ender-3 V3 KE.
    Seit Jahren Anfänger.
    Meine Entwürfe auf Thingi. Was ich gerade drucke.

  • Und was passiert? Der Erste, auf den ich treffe, ist ein Deutscher und mault rum. Unglaublich. :D
    Damit hat sich das Thema "Discourse" für mich erledigt. :D

    Ich werde Klipper auf ein frisches Raspian installieren, so hat das ja keinen Sinn. Strukturiertes Vorgehen ohne Zeitverschwendungen wie Deutsche in internationalen Foren. Den haben die sicher vom Server-Support-Forum geliehen bekommen. :D :D

    Anycubic i3 Mega Klipper –– Qidi X-Smart 3 –– Artillery Sidewinder X2 Octo –– Sidewinder X3 Plus –– Creality Ender-3 V3 KE.
    Seit Jahren Anfänger.
    Meine Entwürfe auf Thingi. Was ich gerade drucke.

    Edited once, last by Hessi ().

  • Öh.. das ist doch alles völlig normales Verhalten? Wenn save_config gemacht wird, wird Klipper IMMER neu gestartet.

    Und die Meldungen im Klippy.log sind einfach nur Statusmeldungen. Oder hab ich hier irgendwo ne Fehlermeldung übersehen?

  • Guter Einwand. Tatsächlich. Ich sehe auch keine Fehlermeldung. Das Mesh-Profil erscheint aber nicht unter Profile.

    Anycubic i3 Mega Klipper –– Qidi X-Smart 3 –– Artillery Sidewinder X2 Octo –– Sidewinder X3 Plus –– Creality Ender-3 V3 KE.
    Seit Jahren Anfänger.
    Meine Entwürfe auf Thingi. Was ich gerade drucke.

  • Guter Einwand. Tatsächlich. Ich sehe auch keine Fehlermeldung. Das Mesh-Profil erscheint aber nicht unter Profile.

    Vielleicht ist das tatsächlich nur ein Bedienungs bzw. Workflow-Missverständnis. Nach dem Bed-Leveln musst Du das Mesh erst mit "BED_MESH_PROFILE SAVE=name" speichern und danach noch mal mit "SAVE_CONFIG" speichern, damit das Ganze persistent ist.


    Beachte auch, dass Klipper per Default *kein* Mesh aktiviert, d.h. Du musst im Start-Makro explizit eines laden, damit es aktiv wird (mit "BED_MESH_PROFILE LOAD=name"). In früheren Klipper Versionen war glaube ich immer das Default-Mesh aktiv, wenn du nicht explizit ein anderes geladen hast.

    Bambu Lab P1S, Voron 2.4, Voron 0.2, Sovol SV01, KP3S, Anycubic i3 Mega S
    (alle Klipper bis auf Bambu)

  • Statt eines Videos.
    Habe die Befehle nun manuell eingegeben, aber auch das klappt nicht.
    Also den SAVE CONFIG-Button ignorieren? Was mache ich mit der Eingabeaufforderung für den Profilnamen? Auf default lassen? Hatte den "Any 04.12.2023" genannt. So wurde er auch angeblich gespeichert.










    Anycubic i3 Mega Klipper –– Qidi X-Smart 3 –– Artillery Sidewinder X2 Octo –– Sidewinder X3 Plus –– Creality Ender-3 V3 KE.
    Seit Jahren Anfänger.
    Meine Entwürfe auf Thingi. Was ich gerade drucke.

    Edited 2 times, last by Hessi ().

  • Manchmal sind Leerzeichen im Namen ein Problem, mach doch mal "mesh60" oder so (für 60 grad druckbett)

    Bambu Lab P1S, Voron 2.4, Voron 0.2, Sovol SV01, KP3S, Anycubic i3 Mega S
    (alle Klipper bis auf Bambu)

  • Deswegen hatte ich es doch manuell ohne Leerzeichen gespeichert. Habe auch x-mal "default" gelassen oder eine Nummer angehängt.

    Anycubic i3 Mega Klipper –– Qidi X-Smart 3 –– Artillery Sidewinder X2 Octo –– Sidewinder X3 Plus –– Creality Ender-3 V3 KE.
    Seit Jahren Anfänger.
    Meine Entwürfe auf Thingi. Was ich gerade drucke.

  • Code
    [stepper_z]
    step_pin: PL3
    dir_pin: !PL1
    enable_pin: !PK0
    microsteps: 16
    rotation_distance: 8
    endstop_pin: ^!PD3
    position_endstop: 0.5
    position_max: 205
    homing_speed: 5.0

    Ich habe mich auch schon gewundert, warum der hintere Teil des Betts verschwindet. Ich kenne diese Ansicht nur vom Qidi, keine Erfahrungen damit, aber da "schwebt" das Bett in der Mitte und klebt nicht unten.

    Mit den Schrauben kann ich nicht noch weiter runter, dann fallen die Einstellräder ab. Der Drucker ist so manuell gelevelt. Hatte ich schon position_endstop: 0.0 ausprobiert. Ändert nichts.

    Gruß
    Michael

    Anycubic i3 Mega Klipper –– Qidi X-Smart 3 –– Artillery Sidewinder X2 Octo –– Sidewinder X3 Plus –– Creality Ender-3 V3 KE.
    Seit Jahren Anfänger.
    Meine Entwürfe auf Thingi. Was ich gerade drucke.

  • Okay, ich habe nun die Bettschrauben justiert, das hat auch sehr gut geklappt. Klipper hat nun seinen Willen bekommen.

    Danach habe ich das Bett gelevelt und die Heightmap schwebte etwas sehr weit oben, aber noch okay. Speichern wollte auch diesmal nicht klappen.


    Dann dachte ich: Mist! Du hat den Probe Z Offset nicht wieder ermittelt. Schnell gemacht und die 6.608 ein Z-Offset und horizontal Movement eingetragen.


    Jetzt säuft die Map wieder so ab wie vorher. Kann es sein, dass er die nicht speichert, weil sie mal zu hoch und mal zu niedrig ist?

    Es ist ein echter BLT mit einer Abweichung bei der Wiederholgenauigkeit von weniger als die Hälfte, die als sehr gute Abweichung in der Klipper-Doku angegeben ist. o,ooo2 wurde ermittelt?


    Es ergibt doch keinen Sinn, den Probe-Z-Offset zu manipulieren, oder?


    EDIT:


    Okay, nun wollte ich schauen, wie weit die Nozzle beim Homing vom Druckbett entfernt ist. Zu weit. Z-Offset ermittelt (Papier) und -0.300 eingetragen. Als position_min noch die Papierdicke addiert: -0.400. Nun meckert er: Unable to parse option 'position_min' in section 'stepper_z'

    Kann essein, dass ich keine negativen Werte eintragen kann?

    Anycubic i3 Mega Klipper –– Qidi X-Smart 3 –– Artillery Sidewinder X2 Octo –– Sidewinder X3 Plus –– Creality Ender-3 V3 KE.
    Seit Jahren Anfänger.
    Meine Entwürfe auf Thingi. Was ich gerade drucke.

    Edited once, last by Hessi ().

  • Ich weiß nicht, ob ich Deine Ausführungen richtig verstanden habe, insb. den Satz "Schnell gemacht und die 6.608 ein Z-Offset und horizontal Movement eingetragen."


    Der Z-Offset unter der Probe ist der Abstand vom Schaltpunkt der Probe zur Nozzle-Spitze, da ja die Probe schalten muss, bevor die Nozzle aufs Bett kracht. Üblicherweise liegt der so in der Größenordnung von 1mm, da kommen mir die 6,608 ziemlich viel vor - vielleicht ist Dein BLTouch falsch montiert?

    Bambu Lab P1S, Voron 2.4, Voron 0.2, Sovol SV01, KP3S, Anycubic i3 Mega S
    (alle Klipper bis auf Bambu)

  • Achso ja und da es ja ein Any mit den getrennt angesteuerten Z-Motoren ist, muss das ganze von der Höhe auch noch mit den Z-Endstops zusammen passen. Wenn die Z-Endstops schalten, geht es ja maximal noch 1-2mm nach unten, bevor der Endstop mechanisch bremst. Um Bett-Unebenheiten auszugleichen dürfen also Z-Endstop, Betthöhe, Probe und Nozzlespitze nicht beliebig weit auseinander liegen...

    Bambu Lab P1S, Voron 2.4, Voron 0.2, Sovol SV01, KP3S, Anycubic i3 Mega S
    (alle Klipper bis auf Bambu)

Disclaimer:
*Externe Links enthalten Affiliate Daten. Wird über diese Links etwas bestellt, erhalten wir eine kleine Provision, Euch kostet es nichts Extra.
**Als Amazon-Partner verdienen wir an qualifizierten Verkäufen.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!

Unread Threads

    1. Title
    2. Replies
    3. Last Reply
    1. Was druckt ihr gerade? Zeigt Mal her! 10k

      • Relaxo
    2. Replies
      10k
      Views
      1.3M
      10k
    3. simonbuhl19

    1. SV08 247

      • Masterofknaeckebrot
    2. Replies
      247
      Views
      18k
      247
    3. Screwii

    1. Wieviel bringt ein Filament Trockner ? 72

      • schaloule
    2. Replies
      72
      Views
      1.5k
      72
    3. PrinterDD

    1. IP Kamera gesucht 18

      • pcDoc
    2. Replies
      18
      Views
      256
      18
    3. JoeBar

    1. BambuLab Smalltalk 4.6k

      • Fritz
    2. Replies
      4.6k
      Views
      320k
      4.6k
    3. PrinterDD