XMAX3 - 32GB EMMC - MCU Protocol error

  • Moin,

    mit etwas kämpfen habe ich die 32GB EMMC zum laufen bekommen (auch nach dem ich den Post zu einem ähnlichen Post gelesen hatte).

    Ich kann die alte 8GB EMMC nicht verwenden, da ich die wohl auf der Suche - warum tut mein WLAN plötzlich nichtmehr - wohl 'verkonfiguriert' habe (ja, wenn man sich nicht alles merkt ... ;( )

    Firmware vorm Update war die 4.3.13.

    Nachdem ich dann den Qidi-Anweisungen zum Uhrzeit/Datum-Problem gefolgt bin (./time.sh), stimmt Datum/Uhrzeit jetzt und ich konnte via FLUIDD die Software aktualisieren.

    Und nun bekomme ich diese Meldung:


    MCU Protocol error

    This is frequently caused by running an older version of the firmware on the MCU(s).

    Fix by recompiling and flashing the firmware.

    Your Klipper version is: v0.11.0-6-g336cc92a

    MCU(s) which should be updated:

    mcu: Current version v0.10.0-530-g3387a9c2-dirty-20221121_013639-mkspi

    MKS_THR: Current version v0.10.0-530-g3387a9c2-dirty-20221210_215217-mkspi

    Up-to-date MCU(s):

    Once the underlying issue is corrected, use the "RESTART" command to reload the config and restart the host software.

    mcu 'MKS_THR': Unable to extract params from: query_thermocouple


    Verstehe ich nicht ganz - ich hab die aktuellste Firmware und die Software (fluidd, klipper, klipper-screen, moonraker...) auf aktuellstem Stand.

    Was kann ich tun, damit dass wieder tut? Ich habe keine große Hoffnung auf Unterstützung durch den Support. In manchen Bereichen bezweifle ich deren Kompetenz oder den Willen zu helfen.... (auch wenn ich denen noch schreiben werde)

    Danke für eure inspirierenden Gedanken, dieses Problem fixen zu können

    Thorsten

    --- scharre nicht bei den Hühnern - flieg wie der Adler ---

  • eigentlich wollte ich den Post bearbeiten - aber ich sehe gerade keinen passenden Button.
    -
    Ähm - ich hab gedacht ich bügel halt die 4.3.13 Firmware erneut rüber - nur bekomme ich jetzt nur noch MACHINE STARTS ABNOMRMALLY und bei jedem Neustart dann wieder in diese Meldung. Ich befürchte ich hab etwas verbockt ...
    Bekommt man das wieder hin oder besser gleich die EMMC noch mal mit dem leeren Image beglücken?

    --- scharre nicht bei den Hühnern - flieg wie der Adler ---

  • eigentlich wollte ich den Post bearbeiten - aber ich sehe gerade keinen passenden Button.
    -
    Ähm - ich hab gedacht ich bügel halt die 4.3.13 Firmware erneut rüber - nur bekomme ich jetzt nur noch MACHINE STARTS ABNOMRMALLY und bei jedem Neustart dann wieder in diese Meldung. Ich befürchte ich hab etwas verbockt ...
    Bekommt man das wieder hin oder besser gleich die EMMC noch mal mit dem leeren Image beglücken?

    Ich würde an deiner Stelle mir hier das offizielle Image von Qidi herunterladen und die EMMC neu flashen. Danach sollte der Drucker wieder laufen.

  • Ich würde an deiner Stelle mir hier das offizielle Image von Qidi herunterladen und die EMMC neu flashen. Danach sollte der Drucker wieder laufen.

    Ich habe genau das QiDi-Image verwendet (hätte ich erwähnen können, stimmt). Von dem her befürchte ich bei einem neuen Versuch, dass ich genau wieder auf dieses Problem stoße, dass ich oben beschreibe.

    --- scharre nicht bei den Hühnern - flieg wie der Adler ---

  • Ich würde an deiner Stelle mir hier das offizielle Image von Qidi herunterladen und die EMMC neu flashen. Danach sollte der Drucker wieder laufen.

    ne das Image ist schrott leider :/


    Ich habe genau das QiDi-Image verwendet (hätte ich erwähnen können, stimmt). Von dem her befürchte ich bei einem neuen Versuch, dass ich genau wieder auf dieses Problem stoße, dass ich oben beschreibe.

    ja, liegt nicht an dir :( bin in den selber Fehler gerannt...

    das Image ist Schrott, da das MCU schon eine höhere Version hat.


    Am besten du schreibst mal den Qidi Support, die müssen das fixen so wie die das aktuell ausliefern kann das bei allen Kunden die bereits das aktuelle Update drin haben, nur nach hinten losgehen.


    Wenn du fit bist, kannst du auch machen was ich gemacht habe:

    unter irgendeinem Live Linux mit dd ein image schreiben von der 8GB emmc, dann dieses image auf die 32GB emmc schreiben mit dd.


    Ich nehme als linux dann direkt gparted live iso, denn wenn man das image auf die neue emmc kopiert hat, muss man man noch die Partition resizen.


    Wenn du dir das unter Linux nicht zutraust, dann such mal hier im Forum nach 32GB... es gab noch nen anderen User der in den Fehler gelaufen und eine Anleitung für Windows User geschrieben hat.

  • ich will ja bewusst nicht das 8GB Image verwenden, da ich das wohl etwas verbockt habe - oder hast du zufällig ein 'natives' originales Image zur Hand?


    (Mit BelenaEtcher müsste ich die 8GB EMMC doch auch als image ablegen können, oder nicht? Aber sonst hab ich irgendwo noch ein Linux - ich glaub sogar ls VM auf meiner Win-Kiste ...)


    Der Support ... was soll ich sagen - aber gut, ich könnte mal ne neue Anfrage losschicken und bitten, das die ein neues Images bereitstellen - mit den passenden MCU Versionen und da der Bambu CF ja gerade im Angebot ist - hab ich so lange was anderes zum drucken ;)

    --- scharre nicht bei den Hühnern - flieg wie der Adler ---

    Edited 2 times, last by Fensterkreuz ().

  • ne das Image ist schrott leider

    Was genau soll an dem Image den Schrott sein. Mal davon abgesehen, das die Software uralt ist. Ich habe damit so einige Flashs durchgeführt.

    das Image ist Schrott, da das MCU schon eine höhere Version hat

    Nicht umsonst steht ja auch auf der Website von Qidi, das nach dem flashen die Firmware aktualisiert werden soll.


    Mit BelenaEtcher müsste ich die 8GB EMMC doch auch als image ablegen können, oder nicht?

    Ja das geht.

  • Ich mag blond sein, oder ungeduldig - nur, sorry diese Diskussion bringt mir nix - ich hatte die aktuelle Firmware drauf, hab das QiDi Image benutzt - und danach dreht sich der Mist in irgendeinem Kreis, weil das Update auf die vorhandene aktuelle FW nix bringt, außer noch mehr 'Ärger'


    leadustin - wie soll ich denn nun vorgehen, wenn ich die aktuelle FW 4.3.13 bereits drauf habe?
    Schritt 1: 32GB EMMC flashen mit dem Image , einbauen, starten, warten - und dann?
    Schritt 2:
    Schritt 3:
    Ich mach's gerne noch einmal - wenn es bei dir getan hat

    --- scharre nicht bei den Hühnern - flieg wie der Adler ---

  • Ich mag blond sein, oder ungeduldig - nur, sorry diese Diskussion bringt mir nix - ich hatte die aktuelle Firmware drauf, hab das QiDi Image benutzt - und danach dreht sich der Mist in irgendeinem Kreis, weil das Update auf die vorhandene aktuelle FW nix bringt, außer noch mehr 'Ärger'


    leadustin - wie soll ich denn nun vorgehen, wenn ich die aktuelle FW 4.3.13 bereits drauf habe?
    Schritt 1: 32GB EMMC flashen mit dem Image , einbauen, starten, warten - und dann?
    Schritt 2:
    Schritt 3:
    Ich mach's gerne noch einmal - wenn es bei dir getan hat

    1. Mit Balena das Image auf die 32gb EMMC flashen.
    2. EMMC einbauen
    3. Drucker starten. Falls nichts passiert. Schritt 4
    4. Das letzte Firmwareupdate herunterladen und die Datei QD_Max_SOC in mksclient.recovery umbennen.
    5. mksclient.recovery in das Root-Verzeichnis eines USB-Sticks kopieren
    6. Stick in den USB-Slot stecken, den Drucker ausmachen und 40 Sekunden warten.
    7. Drucker anstellen - Update sollte starten
    8. Falls nicht wieder ab Punkt 6 beginnen.
  • beim ersten Versuch kam - ABNORMAL START .... ich versuchs nocheinmal .... ist ja Wochenende

    - hab ich jetzt


    EMMC alle Partitionen gelöscht um 120% sicherzugehen, dass da nur ein nacktes xindi-20230309.img drauf ist.

    Geflasht - keine Datei angerührt (first Start wäre ne Option bzgl WLAN, aber ich habs gelassen)

    Eingebaut - gestartet --> System starts abnormally ....
    ausgeschaltet und Drucker ohne EMMC gestartet - System starts abnormally
    alte 8GB EMMC rein - System startet ...
    da muss ich mal drüber nachdenken - im Windows wird die 32GB EMMC ja erkannt und geschrieben.
    Kiste ist jetzt komplett stromlos und ich warte mal länger, dass sich alles löscht ... was ggf irgendwo sitzt. So eine Art BiosReset gibt es bei dem Board nicht, oder?

    --- scharre nicht bei den Hühnern - flieg wie der Adler ---

    Edited once, last by Fensterkreuz ().

  • ok - ich hab den "Recovery-Stick" dann nach einigen erfolglosen Versuchen anstatt des WLAN-Sticks eingesteckt - siehe - da der Fön läuft ... mal sehen wie es weiter geht.

    SOC 2.06

    MCU 2.10.0

    UI V4.3.13

    Per SSH bin ich immer draufgekommen - Web hab ich nicht probiert (Moment ... mit http://192.168.yyy.xxx/#/) geht es nach dem recovery
    Konsole sagt: Last login: Sat Dec 10 01:33:16 2022 (sieht nach "RESET" aus) und Web meint:
    dann druck mal .... erst konfigurieren und so ...
    ok, WLAN wird wieder angezeigt, Verbindung klappt noch nicht - mal sehen.... Ich bedanke mich mach mal weiter ....
    in den Softwareeinstellungen via Web stand (siehe Screenshot) dass ich eine dirty version hätte und hab das recovery ausgeführt (nach timeup.sh) - nun hab ich wieder :( :
    MCU Protocol error
    This is frequently caused by running an older version of the firmware on the MCU(s). Fix by recompiling and flashing the firmware.
    Your Klipper version is: v0.11.0-6-g336cc92a
    MCU(s) which should be updated:
    mcu: Current version v0.10.0-530-g3387a9c2-dirty-20221121_013639-mkspi
    MKS_THR: Current version v0.10.0-530-g3387a9c2-dirty-20221210_215217-mkspi
    rpi: Current version v0.10.0-530-g3387a9c2
    Up-to-date MCU(s):
    Once the underlying issue is corrected, use the "RESTART"
    command to reload the config and restart the host software.
    mcu 'MKS_THR': Unable to extract params from: query_thermocouple


    die Katze beißt sich in den Schwanz ...

    --- scharre nicht bei den Hühnern - flieg wie der Adler ---

    Edited 2 times, last by Fensterkreuz ().

  • Software ist jetzt zwar aktualisiert - dennoch bleibt es bei dem MCUProtokoll error und ich werd nicht schlau daraus ...

    MCU Protocol error
    This is frequently caused by running an older version of the
    firmware on the MCU(s). Fix by recompiling and flashing the
    firmware.
    Your Klipper version is: v0.12.0-230-g0d87bec1-dirty
    MCU(s) which should be updated:
    mcu: Current version v0.10.0-530-g3387a9c2-dirty-20221121_013639-mkspi
    MKS_THR: Current version v0.10.0-530-g3387a9c2-dirty-20221210_215217-mkspi
    rpi: Current version v0.10.0-530-g3387a9c2
    Up-to-date MCU(s):
    Once the underlying issue is corrected, use the "RESTART"
    command to reload the config and restart the host software.
    mcu 'MKS_THR': Command format mismatch: query_adxl345 oid=%c rest_ticks=%u vs query_adxl345 oid=%c clock=%u rest_ticks=%u


    und es wird moniert: Repo has untracked source files: ['klippy/extras/x_twist_compensation.py'] bei Software KLIPPER. Die hab ich dann mal umbenannt (ob das gut ist?)- die Fehleranzeige verschwindet doch der MCU Protokoll Fehler bleibt.
    Bei einer Firmwareneustart kommt dann:
    Section 'x_twist_compensation' is not a valid config section
    Once the underlying issue is corrected, use the "RESTART"
    command to reload the config and restart the host software.
    Printer is halted
    also die Datei doch wieder her ... dann wird aber wieder moniert - echt, es ist zum Mäusemelken

    --- scharre nicht bei den Hühnern - flieg wie der Adler ---

    Edited 2 times, last by Fensterkreuz ().

  • Software ist jetzt zwar aktualisiert - dennoch bleibt es bei dem MCUProtokoll error und ich werd nicht schlau daraus ...

    Von welcher Software sprichst du gerade? Das Firmware-Update von Qidi oder hast du in Fluidd irgendwelche Software aktualisiert. Denn genau da nach sieht es aus. Und das ist das Problem. Du hast jetzt Klipper auf Version 0.12 aktualisiert aber diverse MCU wie der Druckkopf sind noch auf Version 0.10. Daher die Fehlermeldung. Daher nochmal das Qidi-Image flashen und alles von vorn. Wenn alles wieder läuft, darfst du in Fluidd oder KIAUH keine Updates an Moonraker oder Klipper etc. vornehmen.


    Wenn du auf die aktuellste Software updaten willst - Infos dazu in meiner Signatur.

  • echt jetzt - ich war davon ausgegangen, dass ich die Software aktualisieren darf, wenn das da im fluidd steht ... okayyy, ich fange an zu verstehen - ich lese mich mal durch deinen GIT

    --- scharre nicht bei den Hühnern - flieg wie der Adler ---

  • echt jetzt - ich war davon ausgegangen, dass ich die Software aktualisieren darf, wenn das da im fluidd steht

    Leider nein. Auf einem nativen System wäre das kein Problem. Allerdings hat Qidi diverse Änderungen an der Software getätigt. Aktualisierst du nun Klipper etc. kannst du unteranderem den Touchscreen nicht mehr nutzen. Zusätzlich muss zwingend die Firmware für den Druckkopf und den STM erstellt und geflasht werden. Allerdings ist in der moonraker.conf die Benachrichtigung bzgl. Aktualisierungen deaktiviert. Von daher verstehe ich nicht wieso du Updates fahren konntest.

  • bin gerade quer durch deinen offenen QiDi geflogen. Seufz - ich hoffe das tut am Ende alles, Raspis hab ich genug rumliegen ... :)

    Ich kann nicht klagen. Es gibt wohl seitens Qidi ein inoffizielles Image (mit Garantieverlust) mit dem man auf aktuelle Software updaten kann UND das originale Display behalten kann. Ich hatte vor, das am Wochenende mal zu testen. Allerdings gibt es hier auch wieder Modifikationen an Klipper und Moonraker damit das originale Display funktioniert.

  • Ich kann nicht klagen. Es gibt wohl seitens Qidi ein inoffizielles Image (mit Garantieverlust) mit dem man auf aktuelle Software updaten kann UND das originale Display behalten kann. Ich hatte vor, das am Wochenende mal zu testen. Allerdings gibt es hier auch wieder Modifikationen an Klipper und Moonraker damit das originale Display funktioniert.

    das wäre allerdings auch eine Option um nicht neue Hardware kaufen zu müssen- wo bekommt man das Image?

    --- scharre nicht bei den Hühnern - flieg wie der Adler ---

Disclaimer:
*Externe Links enthalten Affiliate Daten. Wird über diese Links etwas bestellt, erhalten wir eine kleine Provision, Euch kostet es nichts Extra.
**Als Amazon-Partner verdienen wir an qualifizierten Verkäufen.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!

Unread Threads

    1. Title
    2. Replies
    3. Last Reply
    1. Bambu Studio Einstellungen Tips und mehr 35

      • PrinterDD
    2. Replies
      35
      Views
      19k
      35
    3. TerryS

    1. Druckerkonvolut (Creality & Sovol)

      • andeyp
    2. Replies
      0
      Views
      27
    1. X1C - Scheiben reinigen 2

      • Nobody4711
    2. Replies
      2
      Views
      61
      2
    3. PrinterDD

    1. Ich suche einen günstigen 3d Drucker 29

      • cdott
    2. Replies
      29
      Views
      646
      29
    3. Joker

    1. RatRig V-Core 4 endlich da! 19

      • MaKe68
    2. Replies
      19
      Views
      928
      19
    3. Monkey47